プラグイン集

無料ブログはココログ
2021年10月
          1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31            

サンプルJS

  • ユーロバカ一代の締切
    ・・・初期化中・・・

« Intel oneAPI をインストールした | トップページ | 親戚の畑を見せてもらった »

2021年8月28日 (土)

msys2のpacmanがdescなんてファイル無いと言った時の対応

8月の2週目ぐらいに、Visual Studio のアップデートと pacman -Syuu やっていたら、
コンピュータがブルースクリーンで落ちた。

Visual Studioの更新は問題なくできたが、msys2 の pacman が openssl/desc が
無くて更新できないとエラーメッセージが表示されるようになった。

https://bbs.archlinux.org/viewtopic.php?id=220552 
によると「空の当該ファイル作れば動くよ」と言う事なので、 touch コマンドで、desc と files を作る。

pacman -S openssl が確かに通るようになったが、コンフリクトのエラーをするようになった。

pacman -S openssl --overwrite=* を付けることで、openssl の強制更新が終わった。
※ pacman -S --force という例をよく見かけるが、
--force は、正しくないオプションと怒られて、動作しない。

pacman -Syuu を実行すると動作するようになり、
2回目にはアップデートするパッケージは無いというメッセージが出るようになったので、
これでやっと直ったことになる。よかったよかった。

« Intel oneAPI をインストールした | トップページ | 親戚の畑を見せてもらった »

パソコン・インターネット」カテゴリの記事

コメント

コメントを書く

(ウェブ上には掲載しません)

« Intel oneAPI をインストールした | トップページ | 親戚の畑を見せてもらった »